Welcome, Guest

Author Topic: Forum fonts question  (Read 701 times)

Offline Dark Angel

  • New Bee
  • *
  • Posts: 8
  • Gender: Male
Forum fonts question
« on: April 04, 2019, 06:12:43 am »
I keep seeing stuff like this around the forum:
"Checkerboarding ….. CBing…….. Nectar Management"

Usually this just means I'm missing the relevant font, but to correct that I kind of need to know which one.
Could someone fill me in please?

Offline sawdstmakr

  • Global Moderator
  • Universal Bee
  • *******
  • Posts: 10771
  • Gender: Male
Re: Forum fonts question
« Reply #1 on: April 04, 2019, 07:50:30 am »
Dark Angel,
I have seen it before also. I suspect it is a glitch in the system that caused it. It might bee data was scrambled during the upload. You could try using the different Fonts Faces above and see if that makes it show up.
Jim Altmiller

Offline Dark Angel

  • New Bee
  • *
  • Posts: 8
  • Gender: Male
Re: Forum fonts question
« Reply #2 on: April 04, 2019, 08:27:27 am »
I see I can change the font my posts are in

But not sure that will change anybody else's posts across the forum.

Offline sawdstmakr

  • Global Moderator
  • Universal Bee
  • *******
  • Posts: 10771
  • Gender: Male
Re: Forum fonts question
« Reply #3 on: April 04, 2019, 08:33:28 am »
I really think it is just a glitch in the system.
Jim Altmiller

Offline sawdstmakr

  • Global Moderator
  • Universal Bee
  • *******
  • Posts: 10771
  • Gender: Male
Re: Forum fonts question
« Reply #4 on: April 04, 2019, 08:46:27 am »
I sent Eivindm a PM of your link. He and Robo are our IT experts. I do not want to bother Robo right now, he is dealing with his deceased fathers estate. Maybe Eivin knows the answer.
Jim Altmiller d

Offline Dark Angel

  • New Bee
  • *
  • Posts: 8
  • Gender: Male
Re: Forum fonts question
« Reply #5 on: April 04, 2019, 04:53:05 pm »
Thanks
I wouldn't say it's overly important, certainly not enough to bother someone that's grieving.  I was just curious is all.

Offline eivindm

  • Global Moderator
  • Field Bee
  • *******
  • Posts: 707
  • Gender: Male
    • Eivind's page
Re: Forum fonts question
« Reply #6 on: April 05, 2019, 05:44:09 pm »
This is a sign of character set problems. There are different character sets out there. In the old days they where most commonly 8 bit (one byte), like ISO 8859. That would give the computer 256 different characters to use. That is OK if you only use one language. ISO 8859-1 defines the character set that I would use in the old days here in Norway. That covers all the special characters we use here. We have three letters here that does not exist in English.

The problem arises when you get more international where people have names with special characters used only some places in the world and not others. If two computers use different character sets, a text file would look differently for many special characters. Basic characters like A-Z and 0-9 are mostly safe, but others could look like gibberish.

To solve this, we got unicode: Today it is most commonly UTF-8 that mostly use 8 bits, but for special characters use up to 32 bits (4 bytes).This way we can share texts with all sorts of special characters, and we can all share the same character set as UTF-8 can define more than two million different characters. So now we avoid confusion about wrong characters, but we still need a font that covers the characters we need. Or else we still get problems where the characters are not shown, but replaced with a square sign or something. And to make even more problems: Sometimes programmers handle text as single bytes during text processing because they don't think and can end up cutting a multi byte character in half. Then we end up with gibberish too.

More and more often this will be OK these days. When I started working as a programmer 15 years ago this could be a big problem. Today it is way better, but from time to time we end up with character problems as 8 bit character sets and programming errors shows up from time to time. Programmers often hate character set handling and time zones (and even more so daylight savings) with a passion. The problems looks so simple, but these problems still hit us from time to time and they can be really hard to track down.

I can't say exactly where this problem happens for the post you refer to. But somewhere between the writers computer, through the server and to your computer some sort of character set confusion is taking place.

Offline Dark Angel

  • New Bee
  • *
  • Posts: 8
  • Gender: Male
Re: Forum fonts question
« Reply #7 on: April 05, 2019, 10:25:02 pm »
Part of that could be that I'm running Linux and not all the fonts are quite the same.  I install things as I find them useful, and probably have a larger font cache than most people due to chasing this sort of thing, but still run into missing ones from time to time.

Offline eivindm

  • Global Moderator
  • Field Bee
  • *******
  • Posts: 707
  • Gender: Male
    • Eivind's page
Re: Forum fonts question
« Reply #8 on: April 06, 2019, 06:21:27 am »
I don't fonts from Linux are the case here. If so, you would have seen square symbols. When it is more random gibberish characters it is more likeley a ISO 8859/UTF-8 conversion problem or cur off of multibyte characters. In other words, I think the problem is present also for readers from Windows.

I am running Linux myself, by the way, and so is the server :-)

Offline Dark Angel

  • New Bee
  • *
  • Posts: 8
  • Gender: Male
Re: Forum fonts question
« Reply #9 on: April 06, 2019, 04:01:23 pm »
Well, as I said, it's more a curiosity thing than anything of real importance.  It could even be a copy-paste issue from when the post I'm referring to was originally made.
Anyway, thanks for the replies.  :smile: